Delayed Webform Submissions

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted Dec 24, 2025 - 19:54 UTC

Identified

We have identified high latency with webform submissions and are currently investigating the issue.
Posted Dec 23, 2025 - 19:09 UTC
This incident affected: Secure Web Forms.