KnowBe4 Academy - Access Issues

Incident Report for KnowBe4

Postmortem

On Wednesday, May 13, 2026, from approximately 18:00 until 18:45 (UTC), some users experienced issues with accessing the KnowBe4 Academy.

This incident was caused by a service disruption with an external service provider. The provider restored service and the Academy returned to normal performance by 18:45 (UTC).

No data loss occurred as a result of this issue.

Posted May 14, 2026 - 19:08 UTC

Resolved

This incident has been resolved.
Posted May 14, 2026 - 13:07 UTC

Monitoring

Access to the KnowBe4 Academy has been restored. We are monitoring to ensure there are no further issues.
Posted May 13, 2026 - 18:48 UTC

Investigating

We are investigating access issues with the KnowBe4 Academy. We will update this page when we have more information.
Posted May 13, 2026 - 18:09 UTC
This incident affected: KnowBe4 Academy.