KMSAT - US Console Performance Issues
Incident Report for KnowBe4
Postmortem

On Monday, 4/27/2021, from approximately 7:41 a.m. until 8:12 a.m. (ET), users experienced issues with accessing the KMSAT US instance of the console. 

These issues were due to a problem that occurred with the scaling function of the KMSAT application which prevented the console from being able to scale for increased traffic. This inability to scale led to the KMSAT platform being unable to adjust for the increased user traffic in the morning. The increase in traffic caused the KMSAT platform to give intermittent 503 errors to users attempting to access the KMSAT console starting at 7:41 a.m. (ET).

To prevent this type of issue in the future, a patch was deployed.

No data loss occurred as a result of this issue.

Posted Apr 28, 2021 - 18:14 UTC

Resolved
This incident has been resolved.
Posted Apr 27, 2021 - 14:00 UTC
Monitoring
We have received reports that the KMSAT console was inaccessible and have deployed a fix. We’re monitoring the results to make sure no further issues occur.
Posted Apr 27, 2021 - 12:16 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console).