KSAT - Login Issues (US Only)
Incident Report for KnowBe4
Postmortem

On Monday, October 21, 2024, from approximately 5:34 p.m. to 6:21 p.m. (UTC), some customers experienced 500 errors and login issues with the KSAT console.

These issues were caused by a code deployment that affected backend caching. This deployment slowed the caching service and caused loading delays and 500 errors for the KSAT console. To resolve this issue, the code deployment was reverted, and the KSAT console returned to normal performance by October 21, 2024, at 6:21 p.m. (UTC).

To prevent this type of issue in the future, we are improving our workflows and coordination between teams when deploying code that will affect caching services.

No data loss occurred as a result of this issue.

Posted Oct 28, 2024 - 20:16 UTC

Resolved
This incident has been resolved.
Posted Oct 21, 2024 - 19:00 UTC
Monitoring
We've implemented a fix for the KSAT login issues and we're monitoring the results to make sure no further issues occur.
Posted Oct 21, 2024 - 18:23 UTC
Investigating
We have received reports that some customers are experiencing 500 errors when logging in to the KSAT console. We are investigating this issue and will update this page when we have more information.
Posted Oct 21, 2024 - 17:44 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).