KSAT - Delayed User Provisioning
Incident Report for KnowBe4
Postmortem

On Wednesday, 05/29/2024, from 1:06 p.m. to 6:06 p.m. (UTC), Active Directory Integration (ADI) syncs in the KnowBe4 console were stuck in a “processing” status.

Upon investigation, we determined that the issue occurred when a software update to a third-party library caused the syncs to stop processing. We corrected the issue by updating our software to match the third-party library’s new format and ADI syncing returned to normal performance by 6:06 p.m. (UTC).

To prevent this issue in the future, we have error alerts to notify us of potential user sync issues so we can catch and respond to problems as soon as possible.

No data loss occurred as a result of this issue.

Posted Jun 11, 2024 - 14:55 UTC

Resolved
This incident has been resolved.
Posted May 29, 2024 - 20:56 UTC
Monitoring
We have deployed a fix to resolve the user provisioning delays affecting KSAT. We will continue to monitor to ensure no further issues occur.
Posted May 29, 2024 - 20:38 UTC
Investigating
We have received reports that some accounts are experiencing delays with User Provisioning in their KSAT Console. We are investigating this issue and will provide updates as we have additional details.
Posted May 29, 2024 - 14:06 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (User Provisioning).