Delay on Phishing Campaigns

Incident Report for KnowBe4

Postmortem

On Wednesday, September 17, 2025, from approximately 12:57 p.m. to 4:21 p.m. (UTC), some customers experienced delayed phishing campaign starts and instances of phishing campaigns not including all assigned users.

These issues were caused by unusually high traffic in the KSAT console, leading to delays for phishing campaigns. To resolve this issue, we improved our code to process phishing campaign queries more efficiently and relieve pressure on the database. The KSAT console returned to normal performance by 4:21 p.m. (UTC).

To prevent this type of issue in the future, our code improvements will allow for better handling of phishing campaign queries during periods of high traffic.

No data was lost as a result of this issue.

Many accounts created duplicate phishing campaigns during this incident. To avoid users receiving duplicate phishing campaign tests, we did not automatically add users back to affected phishing campaigns. If you experienced an instance of a phishing campaign not including all assigned users, we recommend duplicating the original campaign, creating a Smart Group for the missing users, and then including only that Smart Group in the new campaign. For further information, please contact our support team at support.knowbe4.com.

Posted Oct 03, 2025 - 19:31 UTC

Resolved

This incident has been resolved.
Posted Sep 23, 2025 - 19:30 UTC

Monitoring

We’ve implemented a fix for the delayed phishing campaigns and we’re monitoring the results to make sure no further issues occur.
Posted Sep 19, 2025 - 13:29 UTC

Identified

We are currently investigating a delay in phishing campaigns starting.
Posted Sep 17, 2025 - 18:17 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Phishing).