Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 15, 2023 - 07:01 UTC
Scheduled
We will be performing maintenance on all instances of KMSAT on November 16th, 2023 from 2 - 3 a.m. (UTC). For approximately 5 minutes during this maintenance period, features related to the KMSAT console will be unavailable.
Posted Nov 16, 2023 - 02:00 UTC
This scheduled maintenance affected: KnowBe4 Security Awareness Training (KSAT) (Console).