SAT Account Settings not Loading

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted Aug 05, 2026 - 12:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2026 - 19:51 UTC

Identified

We have identified an issue preventing account settings from loading in the SAT console.
Posted Aug 04, 2026 - 19:19 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).