KSAT - Delayed Campaigns - eu.knowbe4.com
Incident Report for KnowBe4
Postmortem

On Monday, August 5th, 2024, from approximately 6:05 p.m. until August 6th, 2024, at 2:05 p.m. (UTC), some customers on the EU instance of the KSAT console experienced issues with starting campaigns, generating reports, adding users to campaigns, and mapping users in SecurityCoach.

This incident was caused by an update to resolve the prior incident KSAT - Campaign Delays that occurred on August 5th, 2024. This update caused the affected tasks to appear to be successful in the backend despite not completing. Another update was deployed to address the issue and restart the processes. The console returned to regular performance by 2:05 p.m on August 6th, 2024.

To prevent this type of issue in the future, we have enhanced our logging and monitoring capabilities to allow for improved visibility into our task processing.

Posted Aug 29, 2024 - 16:47 UTC

Resolved
This incident has been resolved.
Posted Aug 06, 2024 - 17:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 06, 2024 - 12:33 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 06, 2024 - 12:32 UTC
Investigating
We have received reports that campaigns are delayed, as well as reports about other issues with KSAT and SecurityCoach. We are looking into these reports and will update this page when we have more information.
Posted Aug 06, 2024 - 12:00 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).