KSAT - Partner Issues With Loading Accounts
Incident Report for KnowBe4
Postmortem

On Wednesday, 05/15/2024, from approximately 12:35 p.m. until 3:15 p.m. (UTC), some users experienced issues with loading information about accounts in their KSAT console.

This incident was caused when we deployed an update for an upcoming feature. The update unexpectedly affected the index page for accounts, and as a result, partners did not have access permissions for the updated information. Once we added the proper permissions, partners were able to access the page again by 3:15 p.m. (UTC).

To prevent this type of issue in the future, we are increasing additional testing in our workflow to check for similar errors before updates are deployed.

No data loss occurred as a result of this issue.

Posted May 20, 2024 - 16:52 UTC

Resolved
This incident has been resolved.
Posted May 16, 2024 - 13:08 UTC
Monitoring
We’ve implemented a fix for the loading issues with account information, and we’re monitoring the results to make sure no further issues occur.
Posted May 15, 2024 - 15:21 UTC
Investigating
We have received reports that some partners are experiencing loading issues with account information in their KSAT console. We are investigating this issue and will update the page when we have more information.
Posted May 15, 2024 - 14:40 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).