KSAT - Loading Issues

Incident Report for KnowBe4

Postmortem

On Wednesday, January 29, 2024, from approximately 9:37 p.m. to 10:34 p.m. (UTC), some customers experienced issues with loading parts of the KSAT console.

These issues were caused by an update to our Dashboard tab. This update changed how Risk Score values were read and caused errors for areas of the console that used the Risk Score feature. To resolve this issue, we rolled back the update, and the KSAT console returned to normal performance by 10:34 p.m. (UTC).

To prevent this type of issue in the future, we have improved our workflows to include additional manual and automated testing of different KSAT console areas before similar future updates.

No data loss occurred as a result of this issue.

Posted Mar 10, 2025 - 13:54 UTC

Resolved

This incident has been resolved.
Posted Jan 29, 2025 - 22:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2025 - 22:02 UTC

Identified

We have identified general loading issues in the KSAT console. We are working on implementing a fix and we'll update our status page with any new information or updates.
Posted Jan 29, 2025 - 21:52 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).