KMSAT - Email Service Delays (EU Only)
Incident Report for KnowBe4
Postmortem

On Monday, 2/27/2023, from approximately 3:00 a.m. until 11:00 a.m. (ET), some users experienced delays with their KMSAT email services.

This incident was caused by a backend issue with our centralized email service, which delayed email delivery from the EU instance of KMSAT. Once the issue was resolved, KMSAT was able to return to normal performance by 11:00 a.m. (ET). All queued emails were also sent successfully.

To prevent this type of issue in the future, we made a code change and improved how we handle database capacity.

No data loss occurred as a result of this issue.

Posted Mar 03, 2023 - 13:08 UTC

Resolved
This incident has been resolved.
Posted Feb 27, 2023 - 16:03 UTC
Monitoring
We’ve implemented a fix for the delays some users are experiencing with KMSAT email services and we’re monitoring the results to make sure no further issues occur.
Posted Feb 27, 2023 - 15:13 UTC
Investigating
We have received reports that some users are experiencing delays with KMSAT email services. We are investigating this issue and will update this page when we have more information.
Posted Feb 27, 2023 - 13:34 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Email Delivery).