Knowledge Base - Cannot view support ticket history
Incident Report for KnowBe4
Postmortem

On Thursday, 4/18/2024, from approximately 11:00 p.m. until Friday, 4/19/2024 at 4:04 p.m. (UTC), users could not view their support ticket history after we launched our redesigned Knowledge Base at support.knowbe4.com.

This incident was caused by inadvertently excluding the required backend code that displays the support ticket history from the final, released code. We elevated this issue to the highest priority to ensure minimal customer and KnowBe4 support team impact. Once the coding issue was resolved, customers were able to view their support ticket history again by Friday, 4/19/2024 at 4:04 p.m. (UTC).

To prevent this type of issue in the future, we have added more quality assurance and testing rounds to our launch plans.

No data loss occurred as a result of this issue.

Posted May 06, 2024 - 17:51 UTC

Resolved
This issue has been resolved.
Posted Apr 19, 2024 - 22:47 UTC
Investigating
Some design elements are not rendering properly on the KnowBe4 Knowledge Base and as a result, you may not be able to view your support ticket history. We are actively working to correct these issues and will update this page when we have more information.
Posted Apr 19, 2024 - 12:39 UTC
This incident affected: Support.KnowBe4.com.