Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 15, 2026 - 02:00 UTC
Scheduled
We will be performing maintenance on all instances of PasswordIQ on January 15, 2026 from 2:00 a.m. - 3:00 a.m. (UTC). During the deployment window, there may be an up to 20 minute delay in job processing for PasswordIQ.
Posted Jan 13, 2026 - 21:45 UTC
This scheduled maintenance affected: KnowBe4 Security Awareness Training (KSAT) (Console).