Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 27, 2025 - 02:00 UTC
Update
This maintenance has been rescheduled to occur on February 27, 2025 from 2:00 - 3:00 a.m. (UTC).
Posted Feb 04, 2025 - 18:53 UTC
Scheduled
We will be performing maintenance on the Second Chance tool on February 6, 2025 from 2:00 - 3:00 a.m. (UTC). During this maintenance, the Second Chance tool and the Second Chance tab in the KSAT console will be unavailable for approximately 1 hour.
Posted Feb 04, 2025 - 14:51 UTC
This scheduled maintenance affected: KnowBe4 Security Awareness Training (KSAT) (Second Chance).