PhishER Not Loading (US)

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 17:11 UTC

Monitoring

We’ve implemented a fix and are monitoring the results to make sure no further issues occur.
Posted Nov 24, 2025 - 16:02 UTC

Investigating

We have received reports that the US instance of PhishER is not loading. We are investigating this issue and will update this page when we have more information.
Posted Nov 24, 2025 - 15:50 UTC
This incident affected: PhishER (Console).