KSAT - Widespread User Profile Access Issues

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 18:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2026 - 16:16 UTC

Investigating

We have received reports of 500 errors occurring when navigating to user profiles. We are investigating this issue and will update this page when we have more information.
Posted Jun 03, 2026 - 15:07 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).