KMSAT - Slow Console Performance
Incident Report for KnowBe4
Postmortem

On March 21, 2021, from approximately 11:41 p.m. to March 22, 2021 10:46 a.m. (ET), KMSAT users experienced delays with the KMSAT console.

The incident was caused by a slow-running backend process that was slowed down even further due to a sudden increase in customer requests. The slow-running backend process was stopped, allowing the platform to return to normal performance by 10:46 a.m. (ET).

To prevent this type of issue in the future, we have increased the speed of database queries. Other improvements are planned to ensure that a sudden increase in customer requests do not affect overall platform performance.

No data loss occurred as a result of this issue.

Posted Mar 24, 2021 - 18:56 UTC

Resolved
This incident has been resolved.
Posted Mar 22, 2021 - 15:56 UTC
Monitoring
A fix has been implemented and we are currently monitoring the results.
Posted Mar 22, 2021 - 14:59 UTC
Investigating
We’ve received reports that the KMSAT console is running slower than normal. We are looking into these reports and will update this page when we have more information.
Posted Mar 22, 2021 - 12:43 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console).