KMSAT - Message Delays
Incident Report for KnowBe4
Postmortem

On March 1, 2021, from approximately 9:18 a.m. to 1:25 p.m. (ET), KMSAT users experienced message delays that affected the timely delivery of passwordless login, password reset, and account confirmation emails. 

This was caused by an undetected, minor code error which caused some unnecessary traffic to our mail server. Combined with an increase in KMSAT user traffic, this led to significant mail delivery delays. We fixed this code error and by 1:25 p.m. (ET) our mail delivery service was no longer delayed.

No data loss occurred as a result of this issue.

Posted Mar 02, 2021 - 20:28 UTC

Resolved
This issue has been resolved.
Posted Mar 01, 2021 - 19:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2021 - 18:28 UTC
Investigating
We are still investigating this issue. Message delays are still occurring for some customers.
Posted Mar 01, 2021 - 18:12 UTC
Monitoring
The message delays have been resolved and we're monitoring for any further issues.
Posted Mar 01, 2021 - 17:55 UTC
Investigating
We’ve received reports that customers are experiencing delays with receiving confirmation emails, password resets, and password-less login emails. We’re investigating this issue and will update this page when we have more information.
Posted Mar 01, 2021 - 17:24 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Email Delivery).