KSAT - Login Issues
Incident Report for KnowBe4
Postmortem

On Tuesday, 07/23/2024, from approximately 1:14 p.m. to 3:50 p.m. (UTC), some users experienced login issues with the KnowBe4 console.

This incident was caused by excessive server requests from a long-running query on one of our backend databases. To resolve the issue, we removed legacy code that was causing the query, and the KnowBe4 console returned to normal performance by 3:50 p.m.

To prevent this type of issue in the future, we have improved our code to remove the need for the query that caused this issue. No data loss occurred as a result of this issue.

Posted Aug 20, 2024 - 14:13 UTC

Resolved
This incident has been resolved.
Posted Jul 23, 2024 - 20:18 UTC
Monitoring
The issues with KSAT console logins and 500 errors has been resolved. We're monitoring the results to make sure no further issues occur.
Posted Jul 23, 2024 - 16:39 UTC
Identified
We have identified an issue with KSAT console logins and 500 errors. We are working on implementing a fix and we'll update this page with any new information or updates.
Posted Jul 23, 2024 - 14:30 UTC
Investigating
We have received reports that some customers are unable to log in to their KSAT console. We are investigating this issue and will update this page when we have more information.
Posted Jul 23, 2024 - 13:21 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).