Important Note: We recently updated one of our IPs to optimize email deliverability for our Security Awareness Training (KMSAT) and PhishER platforms.

If you're using Office 365 and you've already whitelisted KnowBe4's IPs but are experiencing email deferments or delays, we recommend setting up a receive connector according to the instructions in this article.

Messages may be delayed
Incident Report for KnowBe4
Resolved
This incident has been resolved.
Posted Sep 10, 2019 - 13:28 EDT
Identified
We have identified an issue that has caused delayed activity for some aspects and functionality of our training platform. We have implemented a fix that will prevent additional delays.
Posted Sep 10, 2019 - 12:22 EDT
This incident affected: Kevin Mitnick Security Awareness Training (Training Notifications, Phishing Service).