KMSAT - Download Center Issues (US & EU)
Incident Report for KnowBe4
Postmortem

On Thursday, 11/16/2023, at 2:30 PM (UTC) until Monday, 11/20/2023, at 7:00 PM (UTC), some KMSAT admins could not generate reports with custom date ranges.

This incident occurred after deploying a fix to a separate bug related to reports and date ranges. After identifying the cause of the issue, we reverted the previous bug fix and the report behavior returned to normal performance.

To avoid similar issues in the future, we will add more date and time zone testing to our testing process.

No data loss occurred as a result of this issue.

Posted Dec 01, 2023 - 19:55 UTC

Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 22:02 UTC
Monitoring
We’ve implemented a fix for the download center issue and we’re monitoring the results to make sure no further issues occur.
Posted Nov 20, 2023 - 20:42 UTC
Investigating
We have received reports that some users are experiencing issues with the download center. We are investigating this issue and will update this page when we have more information.
Posted Nov 20, 2023 - 20:08 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Reporting).