KMSAT - Increased Error Rates and Latencies (US Only)
Incident Report for KnowBe4
Postmortem

On Monday, 04/22/2024, from approximately 1:24 p.m. until 2:31 p.m. (UTC), the US instance of the KSAT console experienced elevated error rates and increased latency.

This incident was caused by an overload on our server's CPU due to inefficient data handling in our backend processes. This overload prevented new connection requests from being processed, leading to increased error rates and latency.

Once we identified and fixed the backend processes, the KSAT console returned to normal performance by 2:31 p.m. (UTC).

No data loss occurred as a result of this issue.

Posted May 09, 2024 - 19:32 UTC

Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 21:23 UTC
Identified
We’ve identified the cause of the increased error rates and latencies in the KnowBe4 console. We are working on implementing a fix, and we’ll continue to post on our status page with any new information or updates.
Posted Apr 22, 2024 - 14:40 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).