PAB - Loading Issues

Incident Report for KnowBe4

Postmortem

On Tuesday, February 13, 2025, from approximately 2:04 p.m. to 9:08 p.m. (UTC), some customers experienced increased errors with using the Hybrid Phish Alert Button (PAB) for on-prem Exchange.

These issues were caused by an update to the PAB to support Nested App Authentication Single-Sign On (NAA-SSO). This update introduced new checks for the PAB mode of operation and for shared mailboxes, which caused certain on-prem Exchange PAB deployments to experience errors during these checks. To resolve this issue, we updated the PAB to check for on-prem Exchange and provide an alternative login method if it is detected. The Hybrid PAB returned to normal performance by 9:08 p.m. (UTC).

To prevent this type of issue in the future, we have improved our code to account for the new checks for on-prem Exchange.

No data loss occurred as a result of this issue.

Posted Mar 04, 2025 - 19:49 UTC

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 14:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2025 - 20:49 UTC

Investigating

We have received reports that some customers are experiencing errors when trying to load the Hybrid Phish Alert Button in on-prem Exchange environments. We are investigating this issue and will update this page when we have more information.
Posted Feb 13, 2025 - 14:28 UTC
This incident affected: Phish Alert Button.