Real-Time Coaching campaigns not sending SecurityTips

Incident Report for KnowBe4

Postmortem

On Wednesday, March 5, 2025, from approximately 7:45 p.m. to Friday, March 7, 2025, at 1:30 a.m. (UTC), some customers experienced an issue with SecurityCoach real-time coaching campaigns not sending SecurityTips.

This issue was caused by a prior code update to improve real-time campaign enrollments. This update bypassed a certain callback event, which prevented real-time coaching campaigns from sending SecurityTips for detections. To resolve this issue, we improved the code to account for the callback event. The SecurityCoach console returned to normal performance by March 7, 2025, at 1:30 a.m. (UTC).

To prevent this type of issue in the future, we have also improved our code to verify that the callback event occurs.

No data loss occurred as a result of this issue.

Posted Apr 08, 2025 - 19:51 UTC

Resolved

This incident has been resolved.
Posted Mar 07, 2025 - 12:07 UTC

Monitoring

We’ve implemented a fix for the Real-Time Coaching Campaign issue and we’re monitoring the results to make sure no further issues occur.
Posted Mar 07, 2025 - 02:20 UTC

Identified

We've identified the cause of this issue and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Mar 06, 2025 - 20:51 UTC

Investigating

We have received reports that Real-Time Coaching Campaigns are not sending SecurityTips. We are investigating this issue and will update this page when we have more information.
Posted Mar 06, 2025 - 20:15 UTC
This incident affected: SecurityCoach (Real-Time Coaching Campaigns).