KMSAT - User Provisioning Delays - training.knowbe4.com
Incident Report for KnowBe4
Postmortem

On Friday, 02/02/2024, from approximately 8:05 p.m. to Monday, 02/05/2024, at approximately 1:24 p.m. (UTC), users experienced delays when provisioning users in the US instance of their KnowBe4 consoles.

This incident was caused by a previous incident that affected a backend storage system and prevented jobs from processing. After the initial incident was resolved, the system did not resume processing jobs and our queues became backed up over the weekend. 

Once we increased the resources available to the system to process the backlog of jobs, the KnowBe4 console was able to return to normal performance by 1:24 p.m. (UTC) on Monday.

To prevent this type of issue in the future, we are improving our monitoring processes to track the responsiveness of system processes.

No data loss occurred as a result of this issue.

Posted Feb 09, 2024 - 22:06 UTC

Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 16:29 UTC
Update
We are continuing to monitor for any further user provisioning issues.
Posted Feb 05, 2024 - 21:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 05, 2024 - 14:57 UTC
Identified
We've identified the cause of the user provisioning issues and are working on a fix. We'll update this page when we have more information.
Posted Feb 05, 2024 - 14:34 UTC
Investigating
We have received reports that some users are experiencing delays with user provisioning syncs. We are investigating this issue and will update this page when we have more information.
Posted Feb 05, 2024 - 13:22 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (User Provisioning).