KCM GRC - Slow Loading Issues and 502 Errors
Incident Report for KnowBe4
Postmortem

On Friday, 3/25/2022, from approximately 1:13 p.m. until 3:25 p.m. (ET), some users experienced issues with degraded performance and 502 errors in their KCM GRC platforms.

This incident was caused by an external scan that was looking for vulnerabilities in our KCM GRC product. This external scan caused a high amount of traffic, slowing down KCM GRC's performance.

To resolve the issue, we implemented a strategy to protect the KCM GRC platform from being affected by anomalous high-traffic events. Once this strategy was implemented, KCM GRC was able to return to normal performance by 3:25 p.m. (ET).

This strategy will remain in place to prevent this type of issue in the future.

The platform was not compromised during this incident and no data loss occurred.

Posted Mar 29, 2022 - 17:35 UTC

Resolved
This issue has been resolved.
Posted Mar 25, 2022 - 19:25 UTC
Monitoring
This issue has been resolved. We are continuing to monitor for any further issues and will update this page when we have more information.
Posted Mar 25, 2022 - 18:06 UTC
Investigating
We have received reports that some customers are having issues loading KCM or are getting 502 errors. We are investigating this issue and will update this page when we have more information.
Posted Mar 25, 2022 - 17:45 UTC
This incident affected: KCM GRC (Console).