KSAT - Download Center Issues (US Only)
Incident Report for KnowBe4
Postmortem

On Monday, October 7, 2024, from approximately 4:08 p.m. to 9:29 p.m. (UTC), some customers experienced issues with downloading reports in the Download Center on the US instance of their KSAT console.

This incident was caused by a high number of requests, which backed up the report generation queue. To resolve this issue, we increased the number of simultaneous requests that can be made to the database. This change allowed the backed-up queue of requests to be processed.

We also found and resolved a related issue for partner admins who were unable to generate Training and Phishing Activities reports. This issue was caused by a new CSV setting for reports. Once we adjusted the setting, the reports began generating again.

Once these issues were resolved, the console returned to regular performance by 9:29 p.m. on October 7, 2024.

No data loss occurred as a result of this issue.

Posted Oct 25, 2024 - 19:09 UTC

Resolved
This incident has been resolved.
Posted Oct 07, 2024 - 21:30 UTC
Identified
We’ve resolved the issue with download processing and identified the cause of an issue that partners are experiencing when generating reports. We’re working on implementing a fix and we'll continue to update this page when we have more information.
Posted Oct 07, 2024 - 18:34 UTC
Monitoring
We’ve implemented a fix for the download processing issue and we’re monitoring the results to make sure no further issues occur.
Posted Oct 07, 2024 - 16:58 UTC
Investigating
We have received reports that downloads are processing slowly. We are investigating this issue and will update this page when we have more information.
Posted Oct 07, 2024 - 16:17 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Reporting).