KSAT - Leaderboard and Team Dashboard
Incident Report for KnowBe4
Postmortem

On Friday, November 8, 2024, from approximately 1:28 p.m. to November 11, 2024, at 1:45 p.m. (UTC), customers experienced issues with loading the leaderboard and team dashboard in the Learner Experience (LX).

This issue was caused by a system upgrade that affected the leaderboard and team dashboard features. During this upgrade, updates to both features caused them to revert to a default disabled state. To resolve this issue, both features were re-enabled, and the LX console returned to normal performance by November 11, 2024, at 1:45 p.m. (UTC).

To prevent this type of issue in the future, we are improving our code to ensure that permanent features remain enabled by default, and we are implementing additional checks during updates to determine if a feature should be disabled.

No data loss occurred as a result of this issue.

Posted Nov 20, 2024 - 19:38 UTC

Resolved
This incident has been resolved.
Posted Nov 11, 2024 - 16:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 11, 2024 - 14:21 UTC
Investigating
We are investigating an issue that affects the visibility of the Team Dashboard and Leaderboard in the Learner Experience. We will update this page when we have more information.
Posted Nov 11, 2024 - 13:51 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Learner Experience (LX)).