KSAT Training Login Issues

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 13:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2025 - 21:39 UTC

Investigating

We are investigating an issue affecting the ability to login to KnowBe4 training via the login link in training notifications. Our team is working on this issue and we will update this page when we have more information.
Posted Dec 02, 2025 - 17:50 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Training).