KMSAT - User Provisioning (ADI and SCIM) Issues
Incident Report for KnowBe4
Postmortem

On Thursday, 8/3/2023, from approximately 12:39 p.m. until 5:16 p.m. (UTC), some users experienced issues with user provisioning syncs in their KMSAT consoles.

This incident was caused by a backend upgrade that did not update all the dependent code, which impacted user provisioning. Once the code was updated, KMSAT was able to return to normal performance by 5:16 p.m. (UTC).

To prevent this type of issue in the future, we are adding more research and testing to our workflow.

No data loss occurred as a result of this issue.

Posted Aug 15, 2023 - 15:07 UTC

Resolved
This incident has been resolved.
Posted Aug 04, 2023 - 13:40 UTC
Monitoring
We’ve implemented a fix for the issue causing users to experience issues with User Provisioning, including SCIM and ADI syncs. We’re monitoring the results to make sure no further issues occur.
Posted Aug 03, 2023 - 17:16 UTC
Investigating
We have received reports that some users are experiencing issues with User Provisioning, including SCIM and ADI syncs. We are investigating this issue and will update this page when we have more information.
Posted Aug 03, 2023 - 14:05 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (User Provisioning).