Multiple Products Intermittently Unavailable Due to Azure Front Door Outage (UK Only)

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 20:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2025 - 15:56 UTC

Update

We are aware of a ongoing incident with Azure's Front Door service which is having an intermittent impact on several of our products and features. We are investigating this issue and will update this page when we have more information.
Posted Dec 11, 2025 - 13:30 UTC

Investigating

We are aware of a ongoing incident with Azure's Front Door service. which is having a impact on several our our products and features. We are investigating this issue and will update this page when we have more information.
Posted Dec 11, 2025 - 12:54 UTC
This incident affected: Prevent (Web Add-In, Deployment Center), Protect (Web Add-In), KnowBe4 Security Center, and Defend (Deployment Center).