New EEC Pro Reports Are Unaccessible

Incident Report for KnowBe4

Postmortem

On Wednesday, April 28, 2025, from approximately 9:08 a.m. to 8:21 p.m. (UTC), some customers experienced errors when accessing their Email Exposure Check Pro (EEC Pro) reports.

These issues were caused by a third-party vendor outage that resulted in intermittent errors for EEC Pro during heavy traffic. To resolve this issue, we improved our code to reduce calls to the vendor and stabilize performance. EEC Pro returned to normal performance by April 28, 2025, at 8:21 p.m. (UTC).

To prevent this type of issue in the future, we have also improved our code to enable EEC Pro reporting to function independently during third-party vendor outages.

No data loss occurred as a result of this issue.

Posted May 27, 2025 - 16:12 UTC

Resolved

This incident has been resolved.
Posted Apr 28, 2025 - 19:47 UTC

Monitoring

A fix for this issue has been implemented, and we are currently monitoring the results.
Posted Apr 28, 2025 - 17:39 UTC

Identified

We have received reports that new EEC Pro reports are not accessible. We've identified the cause and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Apr 28, 2025 - 14:52 UTC
This incident affected: Free Tools.