Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 21, 2023 - 21:00 EDT
Scheduled
We will be performing maintenance on the CA instance of the KMSAT console on June 21st, 2023 from 1-2 a.m. (UTC).
For up to 60 minutes during this maintenance period, features related to training and phishing campaigns will be delayed. The rest of the KMSAT console will remain functional.
Posted Jun 08, 2023 - 13:53 EDT
This scheduled maintenance affected: Kevin Mitnick Security Awareness Training (KMSAT) (Phishing, Training, Email Delivery).