PhishER - Unable to Login (US)

Incident Report for KnowBe4

Resolved

This incident has been resolved.
Posted May 08, 2026 - 03:54 UTC

Investigating

We are investigating an issue impacting the ability to login to PhishER in the US instance.
Posted May 08, 2026 - 02:05 UTC
This incident affected: PhishER (Console).