KSAT - Learner Experience Loading Issues
Incident Report for KnowBe4
Postmortem

On Wednesday, September 11th, 2024, from approximately 6:58 p.m. to 9:11 p.m. (UTC), some customers experienced loading issues with the Learner Experience.

This incident was caused by an update that removed legacy code no longer used by one service but was found to still be in use by another service. We restored the code at approximately 8:58 p.m., and the Learner Experience returned to regular performance by 9:11 p.m.

To prevent this type of issue in the future, we have implemented additional testing and additional coordination across teams prior to updating.

No data loss occurred as a result of this issue.

Posted Sep 19, 2024 - 21:04 UTC

Resolved
This incident has been resolved.
Posted Sep 11, 2024 - 21:11 UTC
Monitoring
We have identified an issue where some customers are experiencing loading issues in their Learner Experience and a fix has been implemented. We are now monitoring the results.
Posted Sep 11, 2024 - 19:29 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Learner Experience (LX)).