We have identified an issue with customers signing into PhishER in the UK instance and implemented a fix. Customers should be able to login successfully.
Posted Apr 30, 2026 - 16:47 UTC
Monitoring
We have identified an issue with customers signing into PhishER in the UK instance and implemented a fix which we will continue to monitor. Customers should be able to login successfully.
Posted Apr 30, 2026 - 14:13 UTC
Investigating
We have identified an issue with customers signing into PhishER in the UK instance.