KMSAT - Console Issues (US only)
Incident Report for KnowBe4
Postmortem

On Tuesday, 7/18/2023, from approximately 1:00 p.m. until Wednesday, 7/19/2023, at 8:00 p.m. (UTC), some users experienced delays with their KMSAT phishing campaigns, training campaigns, and training progress updates.

This incident was caused by a backend update that increased the load on the database. As a result, some phishing campaigns, training campaigns, and training progress updates were delayed. Once we reduced the load, KMSAT was able to return to normal performance by Wednesday, 7/19/2023, at 8:00 p.m. (UTC).

To prevent this type of issue in the future, we made updates to optimize our database processes.

No data loss occurred as a result of this issue.

Posted Aug 16, 2023 - 14:46 EDT

Resolved
This incident has been resolved.
Posted Jul 24, 2023 - 11:38 EDT
Monitoring
We’ve implemented a fix for the degraded performance some users were experiencing in their KMSAT consoles, including phishing and training campaigns. We're monitoring the results to make sure no further issues occur.
Posted Jul 21, 2023 - 08:55 EDT
Update
We have received reports that some users are experiencing degraded performance in their KMSAT consoles, including phishing and training campaigns. We've identified a cause of the issues and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Jul 19, 2023 - 14:20 EDT
Update
We've identified a cause of the issues some users are experiencing with their training and phishing campaigns, and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Jul 19, 2023 - 14:01 EDT
Identified
We've identified a cause of the issues some users are experiencing with their training, and are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Jul 19, 2023 - 10:04 EDT
Monitoring
We’ve implemented a fix for the issues some users were experiencing with their training. We’re monitoring the results to make sure no further issues occur.
Posted Jul 18, 2023 - 17:26 EDT
Investigating
We have received reports that some users are experiencing issues with their training. We are investigating this issue and will update this page when we have more information.
Posted Jul 18, 2023 - 15:38 EDT
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console, Phishing, Training).