PhishER - Message Processing Delays
Incident Report for KnowBe4
Postmortem

On Monday, 05/06/2024, from approximately 3:20 p.m. until 6:45 p.m. (UTC), the PhishER platform stopped ingesting messages. 

This incident was caused by a new service deployment that interfered with the PhishER ingester service. This resulted in messages being queued in a backlog but not processed in PhishER. Once the ingester service was restored, the backlog began processing again and PhishER was able to return to normal performance by 6:45 p.m. (UTC). Messages delayed during this incident were fully processed by Tuesday, 05/14/2024.

To prevent this type of issue in the future, we have implemented additional checks to verify that new service deployments will not interfere with existing services.

No data loss occurred as a result of this issue.

Posted May 31, 2024 - 21:08 UTC

Resolved
This incident has been resolved.
Posted May 20, 2024 - 20:52 UTC
Identified
We've identified the cause of the message processing delays that some users are experiencing with their PhishER platform, and we are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted May 06, 2024 - 17:30 UTC
This incident affected: PhishER (Inbox).