Webforms not loading

Incident Report for KnowBe4

Resolved

During a scheduled registrar migration of internal and test domains, a production domain was inadvertently included and not caught in the pre-checks. The initial migration action included updates to the configured Name Servers which resulted in potential service interruptions from 16:00 GMT on March 17 until confirmed full restoration post-propagation at 13:00 GMT on March 18.

We have isolated the process issue and remediated. A review of DNS monitoring options is underway to identify opportunities for faster detection.
Posted Mar 18, 2026 - 14:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2026 - 11:48 UTC

Investigating

We are currently experiencing an issue with Webforms not loading and are currently investigating.
Posted Mar 18, 2026 - 10:33 UTC
This incident affected: Secure Web Forms.