KMSAT - User Profile Pages Not Loading
Incident Report for KnowBe4
Postmortem

On February 17, 2021, from approximately 3:00 to 3:45 p.m. (ET), KMSAT customers were unable to view their users’ profiles or use the manual “Notify Users” functionality on the Overview tab of a training campaign.

These features stopped working due to a minor error in our existing code which was not detected until we deployed a new pagination feature.

We reverted the deployment of the pagination feature to resolve the two issues and then fixed the existing code error.

No data loss occurred as a result of this issue.

Posted Feb 23, 2021 - 17:03 UTC

Resolved
A fix has been implemented and the issue has been resolved.
Posted Feb 17, 2021 - 20:52 UTC
Investigating
We have received reports that since 3 p.m. (ET), some KMSAT user profile pages have not been loading and the Notify Users button on Training Campaign pages is sometimes disappearing when clicked. We have determined the cause of the issue and the issue is actively being resolved.
Posted Feb 17, 2021 - 20:47 UTC
This incident affected: Kevin Mitnick Security Awareness Training (KMSAT) (Console).