Important Note: We recently updated one of our IPs to optimize email deliverability for our Security Awareness Training (KMSAT) and PhishER platforms.

If you're using Office 365 and you've already whitelisted KnowBe4's IPs but are experiencing email deferments or delays, we recommend setting up a receive connector according to the instructions in this article.

KMSAT ModStore and Phishing Service Issues (US & EU)
Incident Report for KnowBe4
Postmortem

At approximately 11:11 a.m. (ET), we discovered a connection issue on our Security Awareness Training platform. The connection issue was identified quickly and a fix was fully deployed by 12:01 p.m. (ET).

Posted Feb 13, 2020 - 12:14 EST

Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 12:01 EST
Investigating
We have had reports that customers are experiencing issues connecting to the ModStore and the Phishing area of our Security Awareness Training platform. We have identified the issue and are currently implementing a fix.
Posted Feb 13, 2020 - 11:11 EST
This incident affected: Kevin Mitnick Security Awareness Training (Training Console, Phishing Service).