KCM GRC - Vendor Module Issues
Incident Report for KnowBe4
Postmortem

On Monday, 5/3/2021, from approximately 11:37 a.m. until 4:20 p.m. (ET), users experienced issues with the Vendor Management and User Administration modules in the KCM GRC console.

This incident was caused by an update to our database driver that negatively impacted the KCM GRC platform. The internal software was reverted to its previous version and the KCM GRC platform returned to normal performance by 4:20 p.m. (ET).

To prevent this type of issue in the future, the database driver will be updated once a fix is released. This update will prevent similar issues with the KCM GRC platform.

No data loss occurred as a result of this issue.

Posted May 05, 2021 - 17:50 EDT

Resolved
This incident has been resolved.
Posted May 03, 2021 - 17:25 EDT
Monitoring
We've implemented a fix for this issue and are currently monitoring the results to make sure no further issues occur.
Posted May 03, 2021 - 16:03 EDT
Investigating
We have received reports that some users are unable to open their vendor issues in the Vendor Risk Management module. We are investigating this issue and will update this page when we have more information.
Posted May 03, 2021 - 14:07 EDT
This incident affected: KCM GRC (Console).