Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 25, 2024 - 00:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 17, 2024 - 14:59 UTC
Scheduled
We will be performing maintenance on the KnowBe4 console on July 25th, 2024 from 12 - 2 a.m. (UTC). For approximately 15 minutes during this maintenance period, features related to PasswordIQ will be unavailable in the KnowBe4 console. The rest of the KnowBe4 console will remain functional.