PhishER Platform Loading Issues (US only)
Incident Report for KnowBe4
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 20:06 UTC
Identified
We've identified the cause of the loading issues some users are experiencing with their PhishER platforms and we are working on implementing a fix. We'll continue to post on our status page with any new information or updates.
Posted Apr 24, 2024 - 15:51 UTC
Investigating
We have received reports that some users are experiencing loading issues with their PhishER platforms. We are investigating this issue and will update this page when we have more information.
Posted Apr 24, 2024 - 13:59 UTC
This incident affected: PhishER (Console).