KSAT - Console latency / pages not loading (EU)

Incident Report for KnowBe4

Postmortem

On November 21, 2025, we deployed a configuration change to KSAT messaging. This deployment caused users to experience intermittent HTTP 500 errors from approximately 10:22 to 15:37 (UTC), and prevented users from logging in or interacting with the EU instance of the KSAT console. To resolve this issue, we rolled back the configuration change, and the KSAT console returned to normal performance by 15:37 (UTC).

No data loss occurred as a result of this issue.

Posted Dec 16, 2025 - 14:23 UTC

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 12:50 UTC

Monitoring

Between 10:10am - 10:25am UTC on 21st of Nov, there was an issue with web pages in the console loading slowly or in some cases, not loading. This issue was quickly identified and resolved.
Posted Nov 21, 2025 - 12:30 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (Console).