KSAT - Planned Maintenance

Scheduled for Apr 1, 02:00 - 03:30 UTC

Update

We will be performing maintenance on all region instances of KSAT on April 2, 2026 at 2:00 a.m. to 3:30 a.m. (UTC). During this maintenance, parts of KSAT may be unavailable for approximately 30 minutes.
Posted Apr 02, 2026 - 02:00 UTC

Scheduled

We will be performing maintenance on all region instances of KSAT on April 2, 2026 at 2:00 a.m. to 3:30 a.m. (UTC). During this maintenance, parts of KSAT may be unavailable for approximately 30 minutes.
Posted Apr 02, 2026 - 02:00 UTC
This scheduled maintenance affects: KnowBe4 Security Awareness Training (KSAT) (Console).