KMSAT - User Provisioning Issues (US Only)
Incident Report for KnowBe4
Postmortem

On Thursday, 04/04/2024, from approximately 1:12 a.m. until 6:45 p.m. (UTC), some users experienced delays when provisioning users in their KnowBe4 Security Awareness Training console. 

The update queue for user provisioning was stopped during a system update on Wednesday night to make sure the system had enough resources for a backend update. After the update, the system did not resume processing jobs and the queue became backed up. 

Once we cleared out the backlog of jobs and restarted the queue, syncs resumed processing and the KnowBe4 console was able to return to normal performance by 6:45 p.m. (UTC).

No data loss occurred as a result of this issue.

Posted May 29, 2024 - 16:50 UTC

Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 14:55 UTC
Monitoring
We’ve implemented a fix for the issue causing users to experience issues with User Provisioning, and we’re monitoring the results to make sure no further issues occur.
Posted Apr 04, 2024 - 20:32 UTC
Investigating
We have received reports that some users are experiencing issues with User Provisioning, including SCIM and ADI syncs. We are investigating this issue and will update this page when we have more information.
Posted Apr 04, 2024 - 17:53 UTC
This incident affected: KnowBe4 Security Awareness Training (KSAT) (User Provisioning).