Cannot log into de.knowbe4.com
Incident Report for KnowBe4
Postmortem

On Tuesday, December 17, 2024, from approximately 1:00 a.m. to 4:00 a.m. (UTC), some customers experienced login errors for the DE instance of the KSAT console.

This issue was caused by unusually high console traffic. The extra load on the database revealed an inefficiency in processing enrollment queries, which caused longer loading times for the console. To mitigate this issue, additional resources were assigned to process the queued queries, and the console returned to normal performance by 4:00 a.m. (UTC).

To prevent this type of issue in the future, we have upgraded our database code to increase efficiency in completing enrollment queries.

No data loss occurred as a result of this issue.

Posted Jan 02, 2025 - 17:47 UTC

Resolved
This incident has been resolved.
Posted Dec 17, 2024 - 16:18 UTC
Monitoring
We experienced db contention issues that affected most processes within the KSAT console. The db issues were resolved and we're now monitoring for residual issues.
Posted Dec 17, 2024 - 04:18 UTC