Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 12, 2024 - 01:00 UTC
Scheduled
We will be performing maintenance on CA and EU instances of the KSAT console on September 12, 2024 from 1 a.m. - 2:30 a.m. (UTC). During this maintenance, CA and EU instances of the KSAT console will be unavailable for approximately 30 minutes.
Posted Sep 06, 2024 - 14:21 UTC
This scheduled maintenance affected: KnowBe4 Security Awareness Training (KSAT) (Console).